Downgrade PHP 7 to PHP 5.6 on Ubuntu 16.04 Xenial

How to install PHP 5.6 on Ubuntu 16.04 Xenial and replace php 7. Let’s assume you have a fresh Ubuntu 16.04 server. Install add-apt-repository: # sudo apt-get install python-software-properties Add repository for PHP 5.6: # sudo add-apt-repository -y ppa:ondrej/php Update package lists: sudo apt-get update Install php5-fpm: # sudo apt-get install php5.6-fpm Check the result: Read more about Downgrade PHP 7 to PHP 5.6 on Ubuntu 16.04 Xenial[…]

Install Apache, Mysql and PHP on Ubuntu 14.04

How to install Apache, MySQL and PHP on Ubuntu 14.04 Update # sudo apt-get update Apache # sudo apt-get install apache2 Install MySQL # sudo apt-get install mysql-server php5-mysql # sudo mysql_install_db # mysql_secure_installation Install PHP # sudo apt-get install php5 libapache2-mod-php5 php5-mcrypt Restart Server # sudo /etc/init.d/apache2 restart Check Apache Open a web browser Read more about Install Apache, Mysql and PHP on Ubuntu 14.04[…]

Plesk autoinstaller GPG error on Ubuntu 14.04 Trusty

Getting error for Plesk auto installer on Ubuntu 12 Trusty: Reading package lists… W: GPG error: http://autoinstall.plesk.com trusty InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 227C38D6AF741DEB W: GPG error: http://autoinstall.plesk.com trusty InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 227C38D6AF741DEB Read more about Plesk autoinstaller GPG error on Ubuntu 14.04 Trusty[…]

A chkconfig alternative to Ubuntu

sysv-rc-conf is an alternate option for Ubuntu. # sudo apt-get install sysv-rc-conf # sysv-rc-conf –list xxxx Also, to disable a process at boot, you could simply disable it by: # sudo update-rc.d apache2 disable and then if you would like to enable it again: # sudo update-rc.d apache2 enable